Using LIDAR to Design
Embankments in ArcGIS

Written by Scott Ralston
U.S. Fish & Wildlife Service
Windom Wetland Management District
This tutorial covers the basics of how to design a dike, embankment or spillway in ArcGIS using a TIN
(Triangular Irregular Network) file from LIDAR data in MN. You can do this process from any set of
elevation data such as a GPS survey once it is converted into a 3D terrain surface called a TIN file. For
more information on using data from a GPS see the supplemental tutorial called Trimble R8 Survey to
ArcGIS Import.
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1. Obtaining LIDAR data: (Skip to Section 2 if you already have data for your county or skip to
Section 7 if you have GPS Data already in a 3d TIN surface from the Trimble R8 Tutorial)
a. This example is specific for users in MN. For other location you will have to consult your
local resources to find if LIDAR data is available in your area or use GPS survey data you
collected.
b. Go to http://www.mngeo.state.mn.us/chouse/elevation/lidar.html
c. Scroll down to Data Download and click on the link MNGeo’s FTP Site
d. In the FTP Directory Click on the “County” Folder

e. Then Click on the County you are working in
f. Within the county folder there is a file called “elevation_data.gdb.zip”. Click on it and
download it. This is a geodatabase with LIDAR for the entire county.

g. These are large files and will take time to download. At times the internet connection
through a VPN like many USFWS offices is slower. Private home DSL networks may
download significantly faster and data can then be transferred back to office servers via
a large flash drive or external hard drive.
h. Once downloaded, unzip the file and store it on your server or other location you keep
GIS data.
i. Rename the file. By default it is “elevation_data.gdb” I would suggest renaming it to the
county it belongs to such as “Countyname_LIDAR.gdb”
j. On the Server it will be a geodatabase file so nothing really usable in the folder. It can
only be opened and viewed in ArcGIS.
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k. If you open ArcMap and hit Add data button and navigate to your new LIDAR file you
will see several files within the geodatabase. The only file you really need is the DEM01
file. If you need to save server space you can delete the other files.

l.

DEM01 is a “Digital Elevation Model” with 1meter resolution which means that if you
zoom in close enough to see individual square pixels that make up the image, each
square represents 1 square meter on the ground and the value for that pixel is the mean
sea level elevation measures in meters.
m. On hard clear surfaces like crop or short grassland LIDAR is usually within about 6 inches
of survey GPS elevation. Less confidence in heavy vegetation like trees & wetlands. It
will generally error on the side of over estimating elevation due to a return from hitting
an obstruction like vegetation. LIDAR does not penetrate water so will return the water
surface only.
n. Make sure you have the spatial analyst and 3d analyst extensions in ArcMap enabled.
On the top menu bar go to Customize, Extensions then check the boxes on all extensions
you need.

2. Clip LIDAR to your work area:
a. County LIDAR files are large. It will be cumbersome and slow to try to work on the entire
county dataset and may result in computer crashes or freeze. Clip out only the area you
need such as the watershed area for your wetland basin.
b. Open ArcMap
3

c. Add whatever data is relevant to you project including the dem01 Lidar file from the
county.
d. You will need a layer that defines your work area such as a project boundary shapefile. If
you don’t already have one then create a new shapefile, start editing it and draw your
work boundary. In this step we will clip the Lidar based on your shapefile so if you have
multiple polygons in the shapefile be aware it will clip to the maximum extent covered
by all polygons in that shapefile. It is best to use a dedicated shapefile with only one
polygon that defines the area you want to clip.
e. Open ArcToolbox (Red Toolbox icon on your top taskbar)
f. In ArcToolbox go to Data Management Tools > Raster > Raster Processing > Clip
g. The input Raster is the Lidar layer for the county you are in. You can drag and drop into
the blank or use the drop down list and scroll down to the right layer. Otherwise you can
also brows to the county LIDAR layer using the folder button
h. The Output Extent is the analysis work boundary layer you created earlier (your cookie
cutter). You can again drag and drop the layer or use the dropdown list or browse to it.
i. The Output Raster Dataset is wherever you want to save the data and whatever name
you want to give it. I would suggest something simple and descriptive such as
LIDAR_meters.
j. Leave the other fields as default and hit the OK button and wait for it to finish the clip

3. Convert Units: Raw LIDAR data may be in meters. We will use the data in meters at a later point
but for much of the design work it may be more useful in feet. (Skip this section if you don’t need
unit conversion)
a. Open ArcToolbox from the red toolbox icon on the top toolbar.
b. Go to Spatial Analyst Tools > Math > Times
c. Input Raster is the LIDAR file you just clipped
d. Constant value is 3.2808 (Conversion factor for meters to feet)
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e. Output rater is wherever you want to save it and what you want to name it. I would
suggest simple naming such as LIDAR_feet
f. Press OK

4. Create a TIN/ 3D Terrain model
a. The raw LIDAR is usable but not visually appealing so a 3D Terrain image called a TIN
(Triangular Irregular Network) is much easier to look at.
b. Again open ArcToolbox (Red toolbox icon)
c. In ArcToolbox go to 3D Analysis Tools > Conversion > From Raster > Raster to TIN
d. Input Raster is the Lidar layer you just clipped and converted units such as LIDAR_Feet
(Drag and drop, use the drop down list or browse to it)
e. Output TIN is the location and filename you want to give the new layer such as
LIDAR3d_feet
f. Z Tolerance is the accuracy vs. the smoothing & generalization, generally we want the
3d terrain to follow very accurate to the original LIDAR data so use a value of 0.5 but if
you have issue of too large of file sizes or don’t need exact detail use the default or pick
a different higher number.
g. Maximum points leave blank.
h. Z Factor is 1 unless for some reason you want to amplify your terrain in which case
elevations will be multiplied by whatever factor you put in. This field could also be used
for doing unit conversions.
i. Hit the OK button to Create your TIN
j. Repeat this process but use the LIDAR_meters input instead and name the output
Lidar3d_meters. You will use the Meters version at a later point for calculating dike
volume.
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5. Displaying your TIN
a. Generally the greater the color gradation the better the visual display of elevation data.
b. Double click on your new TIN/3D Layer or right click and choose properties
c. Look under the Symbology tab and highlight Elevation under the Show Box.
i. Choose your color Ramp, which the default generally works the best (White,
brown, red, yellow, green blue)
ii. Under classes choose 32 which is the maximum unless you don’t want as much
color gradation
iii. Hit the Classify button and choose Natural Breaks which will put more
gradations in areas that have closer elevations to help differentiate change.
iv. Sometimes the color ramp gets flipped so make sure under the default color
scheme that white is your highest elevation and blue is the lowest. If it is
backward, right click over top of the colors in the symbol column and choose
“Flip Symbols”.
d. Under the display tab there is an option for transparency if you want to see an air photo
through the Tin as well.
e. Hit the OK button when you finish setting up your display.
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6. Create Contour Lines
a. Contour lines can be created either from the raw LIDAR layer you clipped or from the 3d‐TIN
layer you created. The Lidar will be more accurate but the TIN layer will be a little smoother
and less cluttered.
b. Again open ArcToolbox (Red toolbox icon)
c. In ArcToolbox go to
i. 3D Analysis Tools > Raster Surface > Contour for creating Contours from your raw
LIDAR
ii. 3D Analysis Tools > Terrain and TIN Surface > Surface Contour for creating Contours
from your 3D TIN
d. Your Input layer is either the Clipped LIDAR or the 3d‐TIN depending which method you
chose
e. Output is wherever you want to save it and your filename such as Contour1ft.shp
f. Contour interval is whatever detail you want. Generally 1 ft but it contour lines are too
tightly packed and it is hard to read on your map you may want 2ft or even 5ft intervals.
Lidar is fairly accurate within about 6 inches so don’t go less than 0.5ft (6inches) contours or
you will be trying to display accuracy that isn’t really there in your raw data.
g. Base contour leave at 0 unless you have a specific elevation you want to start your contour
intervals from
h. Z factor is 1 unless you have a need to exaggerate your elevations or do unit conversions
here.
i. Creating contours from a TIN has a few extra options but leave them default or read the
help menu for details on those items.
j. Hit the OK button to process your contours
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k. Change the display of the finished contour lines if you wish by double clicking on the layer
and use options in the symbology tab to change color, style etc.

7. Creating a virtual dike
a. Display your 3d Lidar Tin you created as well as your contour lines, zoom in to your dike
area. Based on your site survey and/or the contour lines and basic engineering determine
the elevations of your dike and if needed in the design your spillway.
b. This example will be just a basic dike between to valley walls to separate a wetland from a
road right of way. It can be as simple or complicated as you need just take more time to
draw your dike and or spillway.
c. Create a shapefile layer called “Dike_Lines”. It needs to be a “polyline” type of file. This is for
drawing lines not points or polygons. Make sure to define a coordinate system, most likely
using the same the other data such as UTM NAD83 Zone##.
a. To create a new shapefile open ArcCatalog, right click on the folder you want to
store it in, choose new, shapefile
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d. Create a field in the attribute table to record elevation.
i. Open the attribute table for your dike layer
ii. On the table menu bar at the top left click the drop down arrow next to the white
box
iii. Click add field
iv. Name it “Feet”
v. Type, Choose Double
vi. Precision choose 8 (this is the total number of digits allowed)
vii. Scale choose 4 (this is the number of decimal places to use)
viii. Hit OK
ix. In the attribute table you should now have a column called feet
x. Repeat these same steps but create a field called “meters”

e. Start editing your dike shapefile
f. Draw the centerline of your dike
i.
In simple scenarios basically draw a line from a contour line on one side of a valley
to the contour line on the opposite side of the valley.
ii.
Open the attribute table for the dike and in the Feet Field, type in the elevation of
the top of the dike such as 1438.0000
g. Create the dike top width.
i.
You can either manually draw the dike top like you did with the centerline or use
a buffer from the centerline to make it quicker.
ii.
Make sure the centerline is selected/highlighted
iii.
From the editor toolbar drop down menu at the top choose buffer
iv.
In distance enter half of the desired dike top width. i.e. if I want a 10ft dike top I
need to buffer 5ft each side of my centerline. (make sure to type the units in the
blank or it will default calculate to meters)
v.
Hit OK and a buffer should now appear showing the dike top
vi.
Open the attribute table and fill in the elevation in the feet column which if the
dike top is flat will be the same as the centerline elevation
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h. Create the dike slopes
i.
Again you can draw manually or it will be easier and more accurate to use the
buffer tool to create the base of the dike.
ii.
You need to decide on your dike slope grade. Minimum recommendation for
wetland restorations is 5:1 slope.
iii.
You need to determine the maximum height of your dike from base to top. This
may be easiest by counting contour lines. It is more important to overestimate
when creating the dike base to make sure you encompass the entire footprint
which will be important in later volume calculations. If it is estimated at a 6ft high
dike then for easy calculations just use 10ft tall. Math, 5:1 slope on 10ft tall is
5X10=50ft buffer needed from the dike top edgeto the dike base.
iv.
Select the dike top buffer ring so it is highlighted
v.
From the editor toolbar drop down menu at the top choose buffer
vi.
For distance enter the dike base distance you just estimated so in this example
50ft (make sure to type the units in the blank or it will default calculate to meters)
vii.
You will now have a 50ft dike base ring around your dike top ring.
viii.
Open the attribute table and enter the elevation of that dike base ring. Remember
if you over exaggerated use the elevation of the exaggeration. Example if the max
dike height was estimated at 6ft but we used 10ft in our slope/base calculation
then the elevation we enter is 10ft lower than the dike top.
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i.

Convert from feet to meters
i.
ArcGIS uses the units of measurement for the coordinate system to calculate
volume of fill which for UTM coordinates it is in meters so you need to convert all
other measurement units to meters also.
ii.
Open the dike attribute table
iii.
Field calculations only are done on those selected or on all records if none are
selected so select all or none of the dike lines your drew. For a simple dike you
should have 3 sets of lines including centerline, dike top width and dike base all
with elevations entered in the feet column.
iv.
Right click on the top of the meters column and choose field calculator
v.
In the Fields box double click Feet and it will appear in the formula box below.
vi.
Click the * button and it will also be added to the formula below
vii.
The manually type in the formula 0.3048 which is the conversion factor from feet
to meters.
viii.
Press OK and you should see the meters column is now calculated

8. Create a 3d TIN file from your dike
a. Open ArcToolbox (red toolbox icon at the top toolbar)
b. Go to 3D Analyst Tools > Data Management > TIN > Create TIN
c. Output Tin is where you want to save it and what you want to name it such as
DIKE3d_Meters
d. Coordinate system define the same as the other files such as UTM NAD83 Zone ##
e. Input feature class is your Dike layer you just drew
f. Use the dropdown for Height Field and Tag Field to both be “meters”
g. Hit OK and your new 3d dike layer will be made.
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9. Create a LIDAR TIN layer in meters. (If you didn’t already do this in step 4j above)
a. For design purposes you may have used a LIDAR TIN surface in feet units however for
volume calculations all units need to be in meters.
b. Repeat step 4 above for creating a Tin from the LIDAR clip but use the original LIDAR_meters
layer you clipped in step 2 above which would have normally been in meters for the units
from raw county data. If you didn’t have a LIDAR layer in Meters to start with then use the
directions in step 3 to convert a feet units layer to meters using the conversion factor of
0.3048.
c. If you are using GPS data to create your terrain surface instead of LIDAR data then do your
unit conversions for elevation (step 7i above) in the attribute table of the GPS point file to
go from feet to meters and create a TIN using directions from step 8 above to create the 3d
TIN from the GPS point shapefile in the same way you made the Dike TIN.
d. End result is you will have a 3d TIN terrain surface in meters elevation units.
10. Calculate dike volume
a. In ArcToolbox go to 3D Analyst Tools > Triangulated Surface > Surface Difference
b. Input Surface is the LIDAR terrain in meters
c. Reference Surface is the Dike 3d TIN you created in meters
d. Output feature class is the location and name you want to give to the dike cut/fill layer such
as dike_fill
e. Hit OK
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11. Interpreting results
a. You just created a cut/fill layer. Default colors are often green for areas that need to be
filled (which would be the dike you are building) and blue if you were making spillway cut.
b. The cut area can be ignored or even deleted if you were using this method for creating a
dike only. It would be opposite if you were using this method for creating a spillway where
you need to know the cut volume and ignore the fill. Just start editing the layer and select
and delete the parts you don’t need.
c. You can open the attribute table for this new cut/fill layer and select the polygon
representing your dike.
d. Any of the following calculations you can do and record outside of GIS or record and
calculate in new columns in the attribute table using steps outlined above in section 7d to
create new field and use the field calculator to do the math.
e. The Volume is fill needed in cubic meters. Multiply that number by 1.30795 to convert to
cubic yards used by most contractors. Note to contractors that this is compacted volume not
loose volume. Compacted fill is generally about 1.3Xloose fill to haul.
f. The SArea column is square meters footprint area. Do appropriate conversion units to get
into the format that suite you. For example multiply by 10.7639 to get into square feet
g. If you are stripping the dike footprint before building, use the area calculation. Example you
convert from square meters to square feet. Then want to strip 6 inches so take the square
feet multiply by 0.5 which gives you cubic feet. Multiply by 0.037037 to get cubic yards for
contractor estimates.
i.
Often the strip material is pushed to the side during construction then spread
back over the top at the end for better revegetation so this volume of material
could be noted it will be moved twice in estimates.
h. If you require a core trench
i.
Use your measurement/ruler tool in ArcMap to measure the length of the
centerline shown by the dike fill layer
ii.
Determine the depth and width you want the core trench to be (10ft wide is
common if you want to run a sheepsfoot down in the trench, 3ft deep is common
for many standard conditions).
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iii.
iv.
v.

Length X width X depth gives you volume of the core trench in cubic feet.
Multiply by 0.037037 for cubic yards.
Note if this is decent material (clay) it can be used in the downstream toe of the
dike as it is excavated thus deducting this fill volume from the total needed for the
dike. i.e. don’t pay for that volume of material twice.

12. Load Dike footprint into GPS for dike toe staking.
a. For dike footprint delete other polygons (cut areas) so only the dike footprint polygon
remains.
b. Make sure the coordinate system is the same as what you will use in your GPS unit.
c. Copy the shapefile made up of at least 3 files (.dbf, .shp, .shx) to your GPS.
d. For Trimble Access on a TSC3 controller copy to the same location the .job files are
located.
e. In your job setup – Properties of job, under Active Map add the dike shapefile.
f. View and zoom to your location on the map screen and you will see the shapefile
boundaries.
g. Navigate along the edges of the dike footprint on‐screen and place your dike toe stakes
for the contractor.
h. Same can be done for a centerline if you load a centerline file in your GPS.
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Other great Lidar Tools for ArcGIS – The NRCS has a customized toolbox for ArcGIS. Download it from
their website: ftp://ftp.lmic.state.mn.us/pub/data/elevation/lidar/tools/NRCS_engineering/
These tools have a tutorial of their own so details will not be covered here.

1.
2.
3.
4.
5.
6.

Download the toolbox, unzip it and store it wherever you want to store programs.
Open ArcMap and open ArcToolbox (red toolbox icon at the top of the toolbar)
Right click on a blank space in ArcToolbox and hit Add Toolbox from the context menu
Navigate to where you saved the downloaded file
You should now have the NRCS Engineering Tools in your Toolbox
IMPORTANT – a few factors to consider to reduce errors in their toolbox.
a. Sometime you have errors if data layers have different coordinate systems so keep all data in the
same coordinate system
b. This tool does not like file name paths with spaces such as D:\Example Project\ so instead use
underscores such as D:\Example_Project\
c. Unit conversions don’t always work within the program so try to make sure all data has the same
units of measurement. Since UTM coordinate systems measure lat & long in Meters then it is
best to keep all measurements in meters and convert to other units after.
7. Combine some of their tools with steps outline above to simplify the steps such as their tool for
Clipping the LIDAR works great as well as their create contours is also very good. Their hydrology
tools such as defining watersheds and flow paths/stream network are useful.
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